www.schorsch.com

Rayfront 1.0 User Manual

Contact | Sitemap | Search

Preview a Simulation on Windows

The previewer program rview starts rendering the image from the selected viewpoint and gradually improves the resolution of the display until interrupted by user input. Rview will stop its calculation and wait for command input if the resolution of the display has reached the resolution of the graphics device.

Rview is not meant to be a rendering program, and we strongly recommend that you start a background simulation instead for that purpose. Since background simulations don't store the image in memory or update any display of the output, they are much faster and less wasteful of its resources than rview. Rview is intended as a quick interactive program for deciding viewpoints and debugging scene descriptions and is not suited for producing polished images

[Previewer on Windows]

Interface Elements

The program window contains several interaction areas.

Preview Area
The main area is used to display the image currently simulated. The image will be refined iteratively, until some settings are changed, or the program is closed.

Menu Bar
The menu bar is always present along the top of the window, and gives access to all functions, as well as to the other interface elements, while those are hidden.

Tool Bar
The tool bar is normally located below the menu bar, but can be dragged elsewhere, or closed completely. It gives direct access to the most common operations.

Command Bar
The command bar is normally located to the right of the icon bar, but can be dragged elsewhere or closed completely. It allows to enter a number of commands to change simulation settings.

Roll and Pitch Tool
This interface element is located at the right side of the window by default, but can be dragged elsewhere or closed completely. It allows to modify the view pitch and roll interactively.

Yaw and Translate Tool
This interface element is located at the bottom edge of the window by default, but can be dragged elsewhere or closed completely. It allows to change the view point and horizontal direction (yaw) interactively. The view point can be moved along each world coordinate axis, and along each view axis, in smaller and larger increments.

Status Bar
The status bar has it's position fixed to the bottom of the window, but can be switched on or off. It displays short messages about the current state of the program, as well as a few details of your keyboard settings at the time the program was started.

The File Menu

Append view to rif file...

Write the current view into a simulation control file (known as "rad(1) input file" in standalone Radiance use, usually with the extension .rif). Note that the view is simply appended to the file, and previous views with the same name should be removed before using the file again.
Note: Since Rayfront doesn't store view data in simulation control files, use of this command is not recommended.

Append view to view file...

Write the current view into a view file. Select a file name with a standard file open dialog. If the file exists, the parameters of the current view are appended to it, otherwise a new file is created.

Load view from rif file...

Load view parameters from a simulation control file (known as "rad(1) input file" in standalone Radiance use, usually with the extension .rif). First you will select the file with a standard file open dialog, then a second dialog will offer the views found in that file to chose one. The simulation is then restarted with that view.
Note: Since Rayfront doesn't store view data in simulation control files, use of this command is not recommended.

Load view from view file...

Select a view file with a standard file open dialog. The view parameters are taken from the last view entry in the file, and the simulation is restarted with that view.

Save Image

Write the picture to the default file. The default file name is composed like follows: images\<variation>_<viewname>.pic

Save Image as...

Write the picture to a new file with a given name.

Save Log File as...

This function is only available if the simulation has produced any internal warning messages yet. Write the list of those messages to a file with a given name.

View Log File...

This function is only available if the simulation has produced any internal warning messages yet. Display a dialog with the list of those message.

Exit

Quit the previewer. The program will offer to save the image to the default file before exiting.

The View Menu

This menu allows to show or hide all user interface elements except for the menu bar.

The Set Menu

Backface Visibility

When this option is activated (the default), then all faces in the scene are visible from both sides. Otherwise, faces seen from behind are invisible for the viewer.

Grayscale

If this option is activated (off by default), then the simulated image will be displayed in greyscale.

Irradiance

If this option is activated (off by default), then the simulation computes irradiance values instead of the normal radiance values for each point in the image.

Exposure...

Opens a non modal dialog to adjust the exposure of the image display.

Parameters...

Opens a tabbed dialog for modifying most simulation parameters. The tabs include the following values:

Ambient
Value Weight Bounces
Accuracy Divisions Resolution
Super-Samples

Direct
Certainty Jitter Sampling
Threshold Source Visibility

Limit
Reflection Weight

Medium
Scattering Extinction Sampling
Excentricity

Pixel
Sample Threshold

Specular
Jitter Threshold
 
View...

Opens a dialog for modifying the view settings. The view properties to set are a subset of those explained for the normal Rayfront View Editing dialog.

GUI Increments...

This dialog sets the increments that the sliders and spinners in the view manipulation tools are setup with.

The Help Menu

About Winrview...

Displays the version of the program and the copyright information.

Commands...

Displays a list of the commands available in the command bar.

Defaults...

Displays a list of the available simulation parameters and their defaults.

The Toolbar

The toolbar displays a row of icons, each of which offers direct access to a common function that would otherwise only be accessible through the menus, or the command bar.

E

Open the exposure adjustment dialog.

F

Set the focus area of the simulation. The pointer shape changes to a cross, and you are prompted to click and drag on the image display to specify the area where the simulation should continue refining.

N

Restart the simulation.

P

Open the parameter setup dialog.

T

Trace a ray. You will be prompted to click a point in the image, and a ray will be sent into the scene at that point. When the ray is finished, a pop up dialog will display the results, containing the type and properties of the hit surface, the coordinates of the intersection point, and the RGB values as well as the luminance at that point.

V

Open the view settings dialog.

Folder Icon

Load a view from a view file.

Disk Icon

Save the image to a file with a given name.

Question Mark

Open the "About" dialog.

Commands

The command bar accepts the following commands:

aim [ mag [ x y z ] ]

Zoom in by the magnification mag on point x y z. The view point is held constant; only the view direction and size are changed. If x y z is missing, the cursor is used to select the view center with a left click. A negative magnification factor means zoom out. The default factor is one.

exposure [ spec ]

Adjust exposure. The number spec is a multiplier used to compensate the average exposure. A value of 1 renormalizes the image to the computed average, which is usually done immediately after startup. If spec begins with a '+' or '-', the compensation is interpreted in f-stops (ie. the power of two). If spec begins with an '=', an absolute setting is performed. An '=' by itself permits interactive display and setting of the exposure. If spec begins with an '@', the exposure is adjusted to present similar visibility to what would be experienced in the real environment. If spec is absent, or an '@' is followed by nothing, then the cursor is used to pick a specific image location for normalization.

frame [ all ]

Set frame for refinement, selecting the area by clicking and dragging. If "all" is specified, the frame is reset to the entire image.

last [ file ]

Restore the previous view. If a view or picture file is specified, the parameters are taken from the last view entry in the file.

move [ mag [ x y z ] ]

Move camera mag times closer to point x y z . For a perspective projection (or fisheye view), only the view point is changed; the view direction and size remain constant. The view size must be modified in a parallel projection since it determines magnification. If x y z is missing, the cursor is used to select the view center. A negative magnification factor decreases the object size. The default factor is one. Care must be taken to avoid moving behind or inside other objects.

pivot angle [ elev [ mag [ x y z ] ] ]

Similar to the "move" command, but pivots the view about a selected point. The angle is mea­ sured in degrees around the view up vector using the right hand rule. The optional elev is the elevation in degrees from the pivot point; posi­ tive raises the view point to look downward and negative lowers the view point to look upward.

rotate angle [ elev [ mag ] ]

Rotate the camera horizontally by angle degrees. If an elevation is specified, the camera looks upward elev degrees. (Negative means look downward.)

trace [ xorig yorig zorig xdir ydir zdir ]

Trace a ray. If the ray origin and direction are absent, the cursor is used to pick a loca­ tion in the image to trace. The object inter­ sected and its material, location and value are displayed.

Navigation:

Up:
User Manual Overview
     The Simulation Control Center
         Setting up a Simulation
             Running a Simulation

Previous:
Preview a Simulation on Unix
http://www.schorsch.com/en/software/rayfront/manual/rview_win.html
Copyright © 2004-2013 schorsch.com