www.schorsch.com

Rayfront 1.0 User Manual

Contact | Sitemap | Search

Analyze Images on Windows

This functionality is available as a menu item of as a button with the process list. It starts the program "winimage.exe", which is used to display and analyze Radiance format pictures.

You may also convert images (save as) so they can be read by other imaging, paint, or presentation programs. All commands operating within winimage, with the exception of redraw, will result in a new image file being created. The file naming convention in winimage is adding "_" and an abbreviation of the executed command, ie. "fls" for falsecolor(1). Thus, if falsecolor(1) is performed on drawing.pic, the resulting falsecolor(1) image will be drawing_fls.pic. If an annotation is performed on drawing_fls.pic, then the resulting image will be drawing_fls_ann.pic. The original drawing.pic is not overwritten. However, if falsecolor(1) is performed on the same image twice, the second version will overwrite the earlier one.

The File Menu

This menu is used to open Radiance format picture files and store files in other formats. It is not possible to load images in other formats, or to directly store a loaded image in Radiance picture format.

Open

Load a selected picture file.

Close

Close the window of the current image.

Save As

Store the current image in the selected file format.

The Image Menu

This menu offers some general image manipulation operations.

Redraw

Redraw the display of the current image on screen.

Exposure

Adjust the exposure level of the selected image, region, or point with a linear function with clamping. The adjusted image will be given a name and saved as a new. pic file automatically as it is being displayed. This is similar to how a camera works and can only partially compensate for regions of the image which are too bright or too dark. The sky outside of the windows, for example, will appear completely white if the image is exposed for the interior surfaces. To make the image darker by picking a point or region, select a point or region that is bright. To make the image lighter, choose a point or region that is one of the darker areas.

Image

Adjust the exposure by averaging all pixels of an image.

Region

Select the region by clicking and dragging. The enclosed pixels will be averaged and the resulting value used to determine the appropriate exposure. If the image has a washed-out or brightly lit window and a room interior, the window may be selected for exposing. The resulting new image will be of a dimmer interior and a window which seems less bright.

Point

select a point on the image with the cursor. The image will be adjusted with the selected point as the exposure set point.

Rotate

Rotate the current image either per 90 degrees clockwise, or per 180 degrees.

Flip

Flip the current image horizontally or vertically.


The Analysis Menu

This menu offers image operations that are specific to the type of images that Radiance produces. Note that The functions available under the analysis menu result in new images which lose the real-world luminance and illuminance values, i.e. they become unsuitable for further manipulations under the analysis menu.

Human Sensitivity

Similar to an exposure adjustment but uses nonlinear and linear filters to mimic human visual perception. This tool compresses the dynamic range so that most of the details in a high-contrast image may be displayed simultaneously, similar to the visual experience one may have in the actual space.

Image
The human sensitivity tool will consider the entire image to determine the appropriate perceptual exposure setting. The resulting new image may take a few minutes to complete, especially for wide-angle views.

The other variations of this command are not yet available in this version of the program.

False Color

brings up the Falsecolor(1) Dialog Box. When applied to a luminance image, falsecolor(1) outputs (Metric) candela/m2 or (English) footlamberts. When applied to an illuminance image, falsecolor(1) outputs lux or footcandle. Note that you need to set the correct value for the "Quantity" type (luminance or illuminance), since the program has no way to determine which mode the original image was computed with. The number of divisions sets the number of intermediate, equally spaced values between zero and the maxium value that will be displayed on the legend. Show pixel extrema, if selected, will cause falscolor to annotate the image pixel with the max and min luminance or illuminance values.

Iso Contour

Iso contour is similar to falscolor. Both output images with quantitative measurements. Iso contour draws demarcation lines in equal steps, according to number of divisions specified, between zero and the maxium value. Unlike falsecolor(1), the resulting image will contain colored lines of equal value overlayed upon the true color luminance or illuminance image.

Annotate

brings up the annotate dialog box. This tool places text on image. Type the annotation text into the dialog box, press ok, and an updated image with appear with overlay text.


The Window Menu

This menu offers some methods to manage the subwindows in the program.

New Window

Open another window of the same image. This allows different parts of the image to be viewed simultaneously, or for different analyses to be performed and compared side by side.

Cascade

Display all open images in a cascading fashion.

Tile

Display all open images in a tiled fashion.

Arrange Icons

Line up the minimized image icons at the bottom of the winimage window.

Navigation:

Up:
User Manual Overview
     The Simulation Control Center
         Process Management

Previous:
Analyze Images on Unix
http://www.schorsch.com/en/software/rayfront/manual/winimage.html
Copyright © 2004-2013 schorsch.com